Hardware Upgrade Forum

Hardware Upgrade Forum (https://www.hwupgrade.it/forum/index.php)
-   Linux, Unix, OS alternativi (https://www.hwupgrade.it/forum/forumdisplay.php?f=34)
-   -   problemone aggiornamento swaret (https://www.hwupgrade.it/forum/showthread.php?t=680506)


]Rik`[ 08-05-2004 07:24

problemone aggiornamento swaret
 
gente ho un problema assurdo, ho fatto un mega update con swaret, ma non riesce a trovare la libreria libxinerama..e di conseguenza non parte praticamente NULLA sotto X...avete idea di cosa posso fare? grazie!

Mason 08-05-2004 10:45

strano, libxinerama dovrebbe essere sato messo sotto xfree 4.4, se hai aggiornato tutto dovresti aver aggiornato anche quello.

e stato un cambiamento di politica di build delle extension di xfree, dal 4.4 e tutto modulare, mentre prima qualcosa veniva messso come statico,almeno a quanto ho letto

almeno il mio problema con libxinerama e stato questo (quando aggiornato gtk pango glib ecc)

Burns 08-05-2004 11:04

Io ho fatto l'upgrade generale qualche settimana fa e volutamente ho provato a non installare xfree 4.4... ma cos X non partiva pi (mi dava errori su qualche libreria mancante, tra l'altro se non erro c'era anche la libxinerama che non andava bene...). Allora ho aggiornato anche xfree dal 4.3 al 4.4 e adesso va tutto

]Rik`[ 08-05-2004 11:38


 
grazie delle risposte :)
allora vedro' di sistemare XFree 4.4..anche se mi pare strano che non l'ha aggiornato da solo :/

(messaggio mandato da lynx :D :D :D)

]Rik`[ 08-05-2004 11:47


 
argh, ho controllato e non esiste il pkg di XFree86 4.4..installo dai binari o attendo?

Burns 08-05-2004 11:53

Re:
 
Quote:

Originariamente inviato da ]Rik`[
argh, ho controllato e non esiste il pkg di XFree86 4.4..installo dai binari o attendo?
come non c'??

se dai un swaret --search xfree che dice?

a me da diversi pacchetti di xfree, tra i quali c' anche il principale:
xfree86-4.4.0-i486-3 (16184 kB)
io ho installato oltre a questo anche gli altri (font ecc ecc)

]Rik`[ 08-05-2004 13:10


 
bash-2.05b# swaret --search xfree
swaret 1.6.2-1

Listing available Packages matching Keyword: xfree...
xfree86-4.3.0-i486-5 (15567 kB) [Status: NOT INSTALLED (Installed: xfree86-4.3.0-i486-6)]
xfree86-devel-4.3.0-i486-3 (5058 kB) [Status: INSTALLED]
xfree86-docs-4.3.0-noarch-2 (259 kB) [Status: INSTALLED]
xfree86-docs-html-4.3.0-noarch-2 (1144 kB) [Status: NOT INSTALLED]
xfree86-fonts-100dpi-4.3.0-noarch-2 (11953 kB) [Status: NOT INSTALLED]
xfree86-fonts-cyrillic-4.3.0-noarch-2 (365 kB) [Status: NOT INSTALLED]
xfree86-fonts-misc-4.3.0-noarch-2 (16583 kB) [Status: INSTALLED]
xfree86-fonts-scale-4.3.0-noarch-2 (2303 kB) [Status: INSTALLED]
xfree86-src-1.1-noarch-1jim (30 kB) (LinuxPackagesDOTNET.HTTP) [Status: NOT INSTALLED]
xfree86-xnest-4.3.0-i486-3 (1249 kB) [Status: NOT INSTALLED]
xfree86-xprt-4.3.0-i486-3 (920 kB) [Status: NOT INSTALLED]
xfree86-xvfb-4.3.0-i486-3 (1381 kB) [Status: NOT INSTALLED]

ecco quello che mi d a me...mi passi la tua lista di mirror per swaret? io ho s solo quelli trovati sul sito swaret.org..ce ne sono altri? grazie!

NA01 08-05-2004 13:15

usando swaret assicuratevi di avere sempre solo server che si sincronizzino con quelli ufficiali, sono contrario ai server pesonalizzati, mi hanno sempre dato problemi

poi dovete tenere conto che la slack non debian.
quello che scaricate dai repository della slackware current destinato a creare l'iso di un cd, non a far instalare pacchetti a caso.
come tale ogni pacchetto fatto per funzionare con la versione presente sul server della slack.
le librerie sono state risistemate con per funzionare o con x.org o con xfree 4.4(entrambi sui repository).
non contemplato l'uso di binari vecchi in quanto come ho detto la slack non vuole essere una debian. tutto fatto per essere installato da cd o al massimo per essere aggiornato completamente, aggiornamenti parziali possono sempre generare errori ;)

ciao

]Rik`[ 08-05-2004 14:10

Quote:

Originariamente inviato da NA01
usando swaret assicuratevi di avere sempre solo server che si sincronizzino con quelli ufficiali, sono contrario ai server pesonalizzati, mi hanno sempre dato problemi

poi dovete tenere conto che la slack non debian.
quello che scaricate dai repository della slackware current destinato a creare l'iso di un cd, non a far instalare pacchetti a caso.
come tale ogni pacchetto fatto per funzionare con la versione presente sul server della slack.
le librerie sono state risistemate con per funzionare o con x.org o con xfree 4.4(entrambi sui repository).
non contemplato l'uso di binari vecchi in quanto come ho detto la slack non vuole essere una debian. tutto fatto per essere installato da cd o al massimo per essere aggiornato completamente, aggiornamenti parziali possono sempre generare errori ;)

ciao

grazie dell'aiuto :p :D

eclissi83 08-05-2004 14:41

Quote:

Originariamente inviato da NA01
le librerie sono state risistemate con per funzionare o con x.org o con xfree 4.4(entrambi sui repository).

ciao
speriamo che nella prossima release diano la possibilita' di scegliere quale server grafico utilizzare... non mi piace la politica adottata da XFree86 per quanto riguarda la licenza e preferirei installare X.org...

ciriciao

NA01 08-05-2004 14:46

non mi ricordo chi aveva detto che c'era gi.
effettivamente per non lo vedo.....
poi controllo meglio

ciao

Xfree 08-05-2004 16:10

Re:
 
Quote:

Originariamente inviato da ]Rik`[


ecco quello che mi d a me...mi passi la tua lista di mirror per swaret? io ho s solo quelli trovati sul sito swaret.org..ce ne sono altri? grazie!
Ma hai impostato la ricerca su current?? Dal listato pare che la ricerca sia sui mirror 9.1; edita swaret.conf e a version metti current, in questa maniera ti deve comparire di sicuro xfree 4.4 .

NA01 08-05-2004 16:39

io ti consiglio questo
ROOT=ftp://ftp.slackware.no/pub/linux/slackware/slackware-current
ogni 24h sincronizzato con il mirror ufficiale

cia

]Rik`[ 08-05-2004 18:05

Quote:

Originariamente inviato da NA01
io ti consiglio questo
ROOT=ftp://ftp.slackware.no/pub/linux/slackware/slackware-current
ogni 24h sincronizzato con il mirror ufficiale

cia

vabb, ho fatto diversamente..direttamente da xfree.org ho scaricato i binari e ho installato a mano..spero di non aver creato casini :D


Tutti gli orari sono GMT +1. Ora sono le: 16:23.

Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Hardware Upgrade S.r.l.