Hardware Upgrade Forum

Hardware Upgrade Forum (https://www.hwupgrade.it/forum/index.php)
-   Linux, Unix, OS alternativi (https://www.hwupgrade.it/forum/forumdisplay.php?f=34)
-   -   il masterizzatore :-( (https://www.hwupgrade.it/forum/showthread.php?t=858132)


trappola 15-01-2005 08:11

il masterizzatore :-(
 
Ho provato ad installare il masterizzatore su sarge 2.6.8
Naturalmente non va

Dunque collegato come slave secondario, quindi dovrebbe essere hdd, per questo ho modificato fstab aggiungendo questa linea
/dev/hdd /mnt/cdrom1 iso9660 ro,user,noauto 0 0

e ho creato /mnt/cdrom1

il sistema non solo non mi fa il mount automatico, ma anche dando mount /mnt/cdrom1 ma come risposta mi da

mount: can't find mnt/cdrom1 in /etc/fstab or /etc/mtab

sicuramente un problema di impostazione, ma cosa dovrei fare?
Mi pareva di avere letto che con il kernel 2.6.x anche i masterizzatori fossero riconosciuti come ide

Qualche consiglio (o link)?

piero

Braga83 15-01-2005 10:55

B il mount automatico non te lo fa perch lo hai escluso te con l'opzione "noauto".

Ma se dai "mount /dev/hdd /mnt/cdrom1" riesce a montarterlo?

E poi non detto che si chiami per forza hdd, sulla mia suse ad esempio si chiama cdrecorder.

trappola 15-01-2005 12:18

mmmmh in effetti ora si monta con
mount /mnt/cdrom1

ma sul desktop mi appare una icona del cd montato che non scompare smontando ed espellendo, in pi cdrecord -scanbus non mi vede il masterizzatore

wubby 15-01-2005 12:27

Quote:

Originariamente inviato da trappola
in pi cdrecord -scanbus non mi vede il masterizzatore
Dunque alla vecchia maniera:

Codice:

/boot/grub/menu.lst
Trova questa linea simile a questa:
Codice:

# kopt=root=/dev/hda1 ro vga=791 hdc=ide-scsi
Come vedi c' hdc=ide-scsi. Nel tuo caso devi scrivere hdd=ide-scsi
Codice:

update-grub
Aggiorna grub con il comando sopra, riavvia il sistema e poi riprova con cdrecord --scanbus

Per quanto riguarda il problema del mount.
Mostra /etc/fstab
E poi fai ls -l / e mostra quello che ne segue...

:)

trappola 15-01-2005 15:15

Innanzitutto grazie per l'aiuto,

Cominciamo

ho fatto la modifica su /boot/gru/menu.lst ho dato l'update il risultato questo (posto solo la parte senza i cancelletti visto che penso sia quella attiva)

title Debian GNU/Linux, kernel 2.6.8-1-386
root (hd0,0)
kernel /boot/vmlinuz-2.6.8-1-386 root=/dev/hda1 ro hdd=ide-scsi
initrd /boot/initrd.img-2.6.8-1-386
savedefault
boot

title Debian GNU/Linux, kernel 2.6.8-1-386 (recovery mode)
root (hd0,0)
kernel /boot/vmlinuz-2.6.8-1-386 root=/dev/hda1 ro hdd=ide-scsi single
initrd /boot/initrd.img-2.6.8-1-386
savedefault
boot

Effettivamente si aggiunto hdd=ide-scsi nella riga "kernel"

Per l'output di cd record -scanbus questo

debian:/home/piero# cdrecord -scanbus
Cdrecord-Clone 2.01a34 (i686-pc-linux-gnu) Copyright (C) 1995-2004 Jrg Schilling
NOTE: this version of cdrecord is an inofficial (modified) release of cdrecord
and thus may have bugs that are not present in the original version.
Please send bug reports and support requests to <cdrtools@packages.debian.org>.
The original author should not be bothered with problems of this version.

cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.
cdrecord:
cdrecord: For more information, install the cdrtools-doc
cdrecord: package and read /usr/share/doc/cdrecord/README.ATAPI.setup .

Che direi non identifica nessun apparato scsi

il masterizzatore (da /va/log/messages) visto come

hdd: HL-DT-ST GCE-8526B, ATAPI CD/DVD-ROM drive ( un LG)

Infine ecco il fstab

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda1 / ext3 defaults,errors=remount-ro 0 1
/dev/hda6 /home ext3 defaults 0 2
/dev/hda5 none swap sw 0 0
/dev/hdc /mnt/cdrom iso9660 ro,user,noauto 0 0
/dev/hdd /mnt/cdrom1 iso9660 ro,user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0

piero

wubby 15-01-2005 15:16

aggiungi

ide-scsi

a /etc/modules

trappola 15-01-2005 15:41

ok con la modifica a /etc/modules cdrecord -scanbus dice

debian:/home/piero# cdrecord -scanbus
Cdrecord-Clone 2.01a34 (i686-pc-linux-gnu) Copyright (C) 1995-2004 Jrg Schilling
NOTE: this version of cdrecord is an inofficial (modified) release of cdrecord
and thus may have bugs that are not present in the original version.
Please send bug reports and support requests to <cdrtools@packages.debian.org>.
The original author should not be bothered with problems of this version.

Linux sg driver version: 3.5.31
Using libscg version 'schily-0.8'.
scsibus0:
0,0,0 0) 'HL-DT-ST' 'CD-RW GCE-8526B ' '1.03' Removable CD-ROM
0,1,0 1) *
0,2,0 2) *
0,3,0 3) *
0,4,0 4) *
0,5,0 5) *
0,6,0 6) *
0,7,0 7) *
quindi direi che lo vede, ma tentando di montare un cd

piero@debian:~$ mount /mnt/cdrom1

stessa cosa se provo con

piero@debian:~$ mount /dev/hdd
mount: wrong fs type, bad option, bad superblock on /dev/hdd,
or too many mounted file systems
(could this be the IDE device where you in fact use
ide-scsi so that sr0 or sda or so is needed?)

Mi pare di capire che c' un problema nel fatto che usando ide-scsi il file system non va bene ma non saprei come trovare la soluzione

wubby 15-01-2005 15:46

cat /etc/fstab

ls -l /

devo vedere un paio di cose

P.S.
mount /cdrom

per montare un cd

trappola 15-01-2005 15:54

piero@debian:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda1 / ext3 defaults,errors=remount-ro 0 1
/dev/hda6 /home ext3 defaults 0 2
/dev/hda5 none swap sw 0 0
/dev/hdc /mnt/cdrom iso9660 ro,user,noauto 0 0
/dev/hdd /mnt/cdrom1 iso9660 ro,user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0

ho dovuto cambiare il punto di mount dei cd visto che in /media/cdrom ad ogni riavvio mi sparive la directory di mount (e non si ricreava)

wubby 15-01-2005 15:58

ok
mi serve

ls -l /

e poi se fai

mount /cdrom

che succede?

trappola 15-01-2005 16:44

dunque ls -l / dice

piero@debian:~$ ls -l /
totale 132
drwxr-xr-x 2 root root 4096 2005-01-01 16:26 bin
drwxr-xr-x 3 root root 4096 2004-12-06 18:13 boot
lrwxrwxrwx 1 root root 11 2004-11-06 15:37 cdrom -> media/cdrom
drwxr-xr-x 11 root root 24576 2005-01-15 16:27 dev
drwxr-xr-x 92 root root 4096 2005-01-15 16:34 etc
drwxrwsr-x 5 root staff 4096 2004-12-14 20:42 home
drwxr-xr-x 2 root root 4096 2004-11-06 15:38 initrd
lrwxrwxrwx 1 root root 27 2004-11-06 15:39 initrd.img -> boot/initrd.img-2.6.8-1-386
drwxr-xr-x 8 root root 4096 2005-01-01 16:26 lib
drwxr-xr-x 2 root root 49152 2004-11-06 15:36 lost+found
drwxr-xr-x 4 root root 4096 2005-01-15 16:27 media
drwxr-xr-x 4 root root 4096 2005-01-13 23:29 mnt
drwxr-xr-x 2 root root 4096 2004-11-06 15:38 opt
dr-xr-xr-x 95 root root 0 2005-01-15 17:27 proc
drwxr-xr-x 22 root root 4096 2005-01-07 19:50 root
drwxr-xr-x 2 root root 4096 2005-01-04 16:18 sbin
drwxr-xr-x 2 root root 4096 2004-11-06 15:38 srv
drwxr-xr-x 9 root root 0 2005-01-15 17:27 sys
drwxrwxrwt 10 root root 4096 2005-01-15 17:42 tmp
drwxr-xr-x 13 root root 4096 2004-11-28 10:17 usr
drwxr-xr-x 14 root root 4096 2004-12-06 18:10 var
lrwxrwxrwx 1 root root 24 2004-11-06 15:39 vmlinuz -> boot/vmlinuz-2.6.8-1-386


mentre mount /cdrom

piero@debian:~$ mount /cdrom
mount: can't find /media/cdrom0 in /etc/fstab or /etc/mtab

trappola 15-01-2005 16:46

dimenticavo, se serve

mettendo un cd su hdc (il lettore per capirci) parte tutto e si automonta

wubby 15-01-2005 17:00

Quote:

Originariamente inviato da trappola
dimenticavo, se serve
mettendo un cd su hdc (il lettore per capirci) parte tutto e si automonta
Dunque...
/media dovrebbe contenere questo:

Codice:

lrwxrwxrwx  1 root root    6 2004-12-06 20:00 cdrom -> cdrom0
drwxr-xr-x  2 root root 4096 2004-12-06 20:00 cdrom0

Confermi?

trappola 15-01-2005 17:08

pi meno, nel senso che ci sono anche due link

piero@debian:~$ cd /media
piero@debian:/media$ ls -l
totale 8
lrwxrwxrwx 1 root root 13 2005-01-15 16:27 cdrom -> /media/cdrom0
drwxr-xr-x 2 root root 4096 2005-01-15 16:27 cdrom0
lrwxrwxrwx 1 root root 7 2004-11-06 15:37 floppy -> floppy0
drwxr-xr-x 2 root root 4096 2004-11-06 15:37 floppy0
questo il contenuto

wubby 15-01-2005 17:15

Quote:

Originariamente inviato da trappola
lrwxrwxrwx 1 root root 13 2005-01-15 16:27 cdrom -> /media/cdrom0
drwxr-xr-x 2 root root 4096 2005-01-15 16:27 cdrom0
fai puntare cdrom a cdrom0 come riportato da me.

Codice:

cd /media

rm cdrom

ln -s cdrom0 cdrom

e prova a montare il cdrom

mount /cdrom

trappola 15-01-2005 17:25

solito risultato

piero@debian:~$ mount /media/cdrom
mount: can't find /media/cdrom0 in /etc/fstab or /etc/mtab

wubby per, forse ho perso un passaggio dovevo modificare fstab? io ho puntato i mount point non su /media, ma su /mnt.

wubby 15-01-2005 17:34

Quote:

Originariamente inviato da trappola
wubby per, forse ho perso un passaggio dovevo modificare fstab? io ho puntato i mount
point non su /media, ma su /mnt.
Prova cos:

/dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0

trappola 15-01-2005 17:52

ok andata adesso il cd rom (hdc lettore cd/dvd) si monta in automatico in /media/cdrom0

bene ora cosa fare per il masterizzatore? cio hdd che da fstab punta su mnt/cdrom1?

Intendo come lo identifico

wubby 15-01-2005 17:54

Quote:

Originariamente inviato da trappola
ok andata adesso il cd rom (hdc lettore cd/dvd) si monta in automatico in /media/cdrom0

bene ora cosa fare per il masterizzatore? cio hdd che da fstab punta su mnt/cdrom1?

Intendo come lo identifico
Ci penso e te lo dico... ;)

wubby 15-01-2005 18:04

Proviamo... :)

Codice:

cd /media

mkdir cdrw1
ln -s cdrw1 cdrw

cd /

ln -s  media/cdrw1 cdrw

Edita /etc/fstab:

Codice:

/dev/hdd /media/cdrw1 iso9660 ro,user,noauto 0 0
mount /cdrw

Spero funzioni... ;)


Tutti gli orari sono GMT +1. Ora sono le: 07:45.

Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Hardware Upgrade S.r.l.