Hardware Upgrade Forum

Hardware Upgrade Forum (https://www.hwupgrade.it/forum/index.php)
-   Programmi e Utility (https://www.hwupgrade.it/forum/forumdisplay.php?f=37)
-   -   Excel: problematiche e soluzioni (https://www.hwupgrade.it/forum/showthread.php?t=2102242)


zuper 11-04-2010 20:30

Quote:

Originariamente inviato da ses4 (Messaggio 31582994)
Vedo che mentre preparavo la risposta già postata ci sono stati degli sviluppi.
Io credo che tu possa gestire la cosa tranquillamente con il filtro automatico, basta filtrare tutti i valori maggiori di 100 nella colonna E e tutte le celle vuote nella colonna contenente la data di restituzione e hai la situazione completa dei tuoi prestiti.
La formula del mio post precedente non serve per ciò che chiedi, bisognerrebbe implementarla con un'ulteriore condizione, e in ogni caso andrebbe superato il limite dei valori uguali (sarebbe possibile inserendo, oltre alla data del prestito, anche l'ora).
Ciao

assolutamente d'accordo!

Raffaele53 11-04-2010 20:40

....era già tutto scritto, non ricordo dove sono gli occhiali ......
Ho provato in 5 minuti e ho trovato una stringa simile, senza pensare ai filtri.

Modifica 12/04 ----- Ultima rilettura del post.

Riflettendo ieri sera mi sono ricordato una frase..........
>>>>ma solo tra quelli che non presentano data di rientro
Pertanto non esisterebbe nessun dato in VALORE NUMERICO e allora il filtro.....?
Se avevo capito bene il problema la formula lo già scritta.

Ha riguardo che l'utente desiderava "esportare in una lista" i dati per comodita.
Si può fare, ma non capisco l'utilità visto che poi con il filtro ricavi solo i superiori a 100

=SE(...................................;OGGI()-B1)...)
L'ho messo per vedere quanti giorni è fuori, puoi anche mettere ""
Al limite togli dati sensibili e sposta il files

PixXelite 12-04-2010 13:48

volevo allegare un screenshot del lavoro da fare ma mi è impossibile ridurre l'immagine a 24Kb non si capisce una cippa.
Come posso fare? Scusate ma cosi almeno ci capiamo meglio visto che vedo le tante risposte (anzi...GRAZIE MILLE per l'interessamento)!!

PixXelite 12-04-2010 14:04

Quote:

Originariamente inviato da PixXelite (Messaggio 31590770)
volevo allegare un screenshot del lavoro da fare ma mi è impossibile ridurre l'immagine a 24Kb non si capisce una cippa.
Come posso fare? Scusate ma cosi almeno ci capiamo meglio visto che vedo le tante risposte (anzi...GRAZIE MILLE per l'interessamento)!!

ok dovrebbe funzionare cosi..immagine esempio

cosi almeno riporto tutto a modo...ho messo anche delle note esplicative.

Grazie ancora

Raffaele53 12-04-2010 17:04

La formula e sbagliata, in R9 non c'è scritto nulla.
Se scrivi---> =SE(E2<>0;SE(E2>100;A2;"");"") ------corretta ;"" finali

Adesso appaiono anche Caio e Ubaldo in Articolo1, non li desideri vedere?
Allora------> =SE(D2="";SE(E2>100;A2;"");"") ------corretta ;"" finali

Il resoconto sotto..., potrebbe andare bene ...??????
Maggiori di Articolo1, sotto Articolo1
Maggiori di Articolo2, sotto Articolo2
Maggiori di Articolo3, sotto Articolo3

Per finire una volta segnalati, questi dati devono essere spostati a loro volta sotto per far posto ai nuovi oppure si possono cancellare?
Rispondi, nel frattempo vado a cercarmi come si riordina sotto il tutto, sempre che puoi cancellarli.
Era fatto con una macro che scriva direttamente sotto riordinandoli. VBA non lo conosco.

ses4 12-04-2010 17:22

Quote:

Originariamente inviato da PixXelite (Messaggio 31590985)
ok dovrebbe funzionare cosi..immagine esempio

cosi almeno riporto tutto a modo...ho messo anche delle note esplicative.

Grazie ancora

Non vedo nulla, mi da errore.
Ciao

PixXelite 12-04-2010 18:54

Quote:

Originariamente inviato da Raffaele53 (Messaggio 31593629)
La formula e sbagliata, in R9 non c'è scritto nulla.
Se scrivi---> =SE(E2<>0;SE(E2>100;A2;"");"") ------corretta ;"" finali

Adesso appaiono anche Caio e Ubaldo in Articolo1, non li desideri vedere?
Allora------> =SE(D2="";SE(E2>100;A2;"");"") ------corretta ;"" finali

ciao, datti pace ma non ho ben compreso....R9 cosa c'entra? La colonna R mi serve solo di riserva e cmq per staccare i vari articoli.

le celle E2 ed D2 non contengono alcun dato (perchè facenti parte della cella unita di intestazione dell' "Articolo 1")...forse ho uppato male le immagini e non sono chiare?

la prima nota in centro appena sotto la tabella principale sta ad indicare che le celle da E4 ad E9, le celle da K4 a K9 e le celle da Q4 a Q9 contengono la funzione =SE(D4=0;OGGI()-B4;D4-B4) ovviamente con le modifiche di posizionamento relativo alle celle perchè l'esempio appena scritto vale solo per la cella E4 mentre per la cella Q7 è =SE(P7=0;OGGI()-N7;P7-N7)...e queste funzioni vanno bene.

non ho capito dove la funzione sia sbagliata...scusami ma dopo 10 ore di lavoro ho la testa che fuma....roba bona eh!!:banned:

PixXelite 12-04-2010 19:11

credo ci siano stati dei problemi con l'altra immagine...ora posto un altro link...
grazie della pazienza
link immagine 2

ditemi se da' problemi...
ses4 cosa mi dici..la vedi?

ses4 12-04-2010 19:49

Quote:

Originariamente inviato da PixXelite (Messaggio 31595475)
credo ci siano stati dei problemi con l'altra immagine...ora posto un altro link...
grazie della pazienza
link immagine 2

ditemi se da' problemi...
ses4 cosa mi dici..la vedi?

Vista.
Una formula che faccia ciò che chiedi per 90 articoli disposti in quel modo non credo ci stia in una cella.
Secondo me l'organizzazione del foglio non va bene.
Lascerei la struttura delle colonne da A a E aggiungendo una colonna in cui inserire l'articolo in modo da avere una lista a sviluppo verticale facile da gestire per ogni esigenza, compresa la creazione dell'elenco delle persone da contattare tramite filtro automatico.
Ciao

emmedi 12-04-2010 20:03

Li si vedono solo 3 oggetti in prestito. Realmente quanti ne hai?

Raffaele53 12-04-2010 20:05

Anchio sono fumato...... Anche la Tua funziona

Il tutto era riferito alla frase
>>>Avrei fatto qualche passo in piu inserendo nella colonna F la funzione =se(D4<>=;"";se(E4> 100);A4;"")

Sicuramente le avevi riscritte anche nelle colonne L e R
Riscritta in R9 non mi dava risultato solo perchè l'ho copiata male.
Era meglio che spostavi un foglio excel.

Meglio seguire il suggerimento di ses4 ...

PixXelite 13-04-2010 15:26

Quote:

Originariamente inviato da ses4 (Messaggio 31595940)
Vista.
Una formula che faccia ciò che chiedi per 90 articoli disposti in quel modo non credo ci stia in una cella.
Secondo me l'organizzazione del foglio non va bene.
Lascerei la struttura delle colonne da A a E aggiungendo una colonna in cui inserire l'articolo in modo da avere una lista a sviluppo verticale facile da gestire per ogni esigenza, compresa la creazione dell'elenco delle persone da contattare tramite filtro automatico.
Ciao

eh si...questo lo avevo pensato anche io sopratutto perchè facendo cosi avevo le colonne già impostate, il fatto è che vanno aggiunte nuove date ogni volta (è difficile da spiegare, ma l'elenco lo aggiornano ogni giorno più persone)e si dovrebbe ogni volta anzichè aggiungere solo il dato (attraverso anche un form possibilmente) inserire un riga nuova, formattarla e inserire i dati (capisci che se lo dai in mano a persone che il computer lo accendono e spengono e basta hai fatto la frittata al secondo inserimento :D )

Gli articoli sono circa 90 in tutto

Raffaele53 13-04-2010 17:26

1 Allegato(i)
sono ancora fumato
ho preparato un esempio poco ortodosso, per avere il risultato voluto (almeno spero).

Come detto la formula doveva far vedere tutti quelli che avevano superato 100 giorni senza restituire il libro. L'ho rimodificata e la vedi corretta nelle colonne F,L,R scritte in rosso.

Macro4 (questa è fatta solo per 3 colonne) - la potrai ampliare anche 100/200 colonne
Purtroppo dovrai eseguirla TU sul foglio Tuo.

Questa Macro4, ricopia le tre colonne F,L,R nel foglio2 e poi "traspone" le prime righe (ideale 90 righe) nel foglio3 .Ora mi è venuto in mente che lasciando libere le prime tre colonne sul foglio3 e non una come ho fatto io vedrai il risultato (piccola aggiunta) nelle colonne B e C
Se all'apertura del files Ti dice che c'è una macro dovrai abbassare il livello a Excel.

PixXelite 13-04-2010 17:54

scuasate ma ho avuto un down sulla linea da oggi alle 14...insomma...HO FATTO!!!!!

senza usare VBA (che non ne so nulla) solo puro excel...è venuto il tutto un po' arzigogolato ma...FUNZIONA!!!

xRaffaele53...appena posso do' un occhio al tuo prototipo e ti ringrazio davvero tanto per l'assistenza....come a tutti ovvio!!!

....ho provato a zippare il file di esempio finito e completo ma mi risulta di 28K (che sfortuna!!) ora mi registro in qualche server per hosting e posto il link al file...a presto

PixXelite 13-04-2010 18:00

ok...fatto...almeno spero...proviamo
...excel file pixxelite
...come al solito in caso di probl avvertite pls.

Ovviamente essendo la colonna F,L,R,X,AD solo computazionale va' nascosta...inoltre vanno filtrati i risultati nella scheda "da contattare" con filtro-->personalizza...-->diverso da #N/D cosi risultano le persone che hanno ancora l'oggetto da più di 100 giorni...

provate per esempio a mettere un nome a caso in data uscita tipo 11/09/2009 e vedrete apparire il nome nella lista

cosa ne dite? Può andare?

PixXelite 13-04-2010 18:10

ahhhh...questi hosting file!!...


mi sembrava ci fossero dei problemi col downlaod corrotto...quindi ho cAMbiato sito
...prova da qui pls....link file 2

thx

cavalloplus 13-04-2010 19:18

[EXCEL] funzione somma....... c'è un perchè non guardate solo il titolo
 
ciao a tutti

ho un problema a fare una funzione con excel.... è una somma vi spiego cosa vorrei fare.

ho dodici colonne che indicano i mesi e come righe dei numeri nella tredicesima colonna ho la somma delle diverse righe

ora mi chiedo se è possibile fare una somma parziale ma automatica cioè partendo da una cella fissa che è quella relativa al mese di gennaio fare la somma delle 5 celle successive e quel 5 è un valore che metto io in un'altra cella...
è possibile?

ciao e grazie

cavalloplus 13-04-2010 19:19

ah dimenticavo.... non vorrei fare una cascata di se()....

Raffaele53 13-04-2010 20:30

>>>Ovviamente essendo la colonna F,L,R,X,AD solo va' nascosta...
Computazionale Non l'ho capisco, nasconderla/chiuderla era ovvio.

Ho notato che finalmente hai cambiato formula, adesso in X9 hai "1" (invece del nome un numero)
Ho notato che hai trascinato giù la formula sino a B561 (sempre nella speranza che un domani siano sufficenti).
Però nella formula INDICE persone da contattare è limitato il range.

Domanda .... gli articoli rimaranno sempre 90???
Ammettiamo che gli articoli diventino 91? Devi rimodificare il files.

Può andare bene, anche se personalmente preferisco una macro.
Ps.Cambia hosting

Raffaele53 13-04-2010 21:03

Stavo staccando e velocemente ho pensato questo.....

Se ti va bene scrivi =SOMMA(A$1:B1)
Dopo la trascini per 11 colonne a destra, dopo in basso quanto vuoi.


Tutti gli orari sono GMT +1. Ora sono le: 23:20.

Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Hardware Upgrade S.r.l.